aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-10-27 15:39:41 +0100
committerTimo Weingärtner <timo@tiwe.de>2013-10-27 16:13:04 +0100
commit116b90ec29b8e0911aa1eb8dfa5d9c185742ab85 (patch)
tree4d55ff636da9a65822561b166e1e20320332a9c0
parent127998372577ce6f9640d080bc0e208ddc53f8a9 (diff)
downloadssh-agent-filter-debian-bpo-wheezy.tar.gz
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rw-r--r--debian/gbp.conf2
-rw-r--r--debian/patches/backport23
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/ssh-agent-filter.lintian-overrides2
7 files changed, 41 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 43fe777..d76ce48 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ssh-agent-filter (0.3-1~bpo70+1) wheezy-backports; urgency=low
+
+ * Rebuild for wheezy-backports.
+ * Explicitly use g++-4.7.
+ * Build-Depend on pandoc (<< 1.11.1-4) instead of pandoc-data,
+ add lintian-overrides for hyphen-used-as-minus-sign.
+ * Replace (map|set)::emplace with insert.
+
+ -- Timo Weingärtner <timo@tiwe.de> Sun, 27 Oct 2013 16:05:16 +0100
+
ssh-agent-filter (0.3-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index 0e9ce43..dde9297 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ssh-agent-filter
Section: net
Priority: extra
Maintainer: Timo Weingärtner <timo@tiwe.de>
-Build-Depends: debhelper (>= 9), nettle-dev, libgmp-dev, libboost-program-options-dev, libboost-filesystem-dev, bash-completion, help2man, pandoc, pandoc-data
+Build-Depends: debhelper (>= 9), nettle-dev, libgmp-dev, libboost-program-options-dev, libboost-filesystem-dev, bash-completion, help2man, pandoc (<< 1.11.1-4), g++-4.7
Standards-Version: 3.9.4
Homepage: https://github.com/tiwe-de/ssh-agent-filter
Vcs-Git: git://github.com/tiwe-de/ssh-agent-filter.git -b debian
diff --git a/debian/gbp.conf b/debian/gbp.conf
index 305e4dc..1f04bde 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -1,5 +1,5 @@
[DEFAULT]
upstream-branch=master
upstream-tag=%(version)s
-debian-branch=debian
+debian-branch=debian-bpo-wheezy
pristine-tar=true
diff --git a/debian/patches/backport b/debian/patches/backport
new file mode 100644
index 0000000..9e2ccdd
--- /dev/null
+++ b/debian/patches/backport
@@ -0,0 +1,23 @@
+Description: Replace (map|set)::emplace with insert.
+Author: Timo Weingärtner <timo@tiwe.de>
+
+--- ssh-agent-filter-0.3.orig/ssh-agent-filter.C
++++ ssh-agent-filter-0.3/ssh-agent-filter.C
+@@ -245,7 +245,7 @@ void setup_filters () {
+ if (debug) std::clog << "key allowed by matching comment" << std::endl;
+ }
+
+- if (allow) allowed_pubkeys.emplace(std::move(key));
++ if (allow) allowed_pubkeys.insert(std::move(key));
+ else {
+ bool confirm{false};
+
+@@ -266,7 +266,7 @@ void setup_filters () {
+ if (debug) std::clog << "key allowed with confirmation by catch-all (-A)" << std::endl;
+ }
+
+- if (confirm) confirmed_pubkeys.emplace(std::move(key), std::move(comm));
++ if (confirm) confirmed_pubkeys.insert(make_pair(std::move(key), std::move(comm)));
+ }
+
+ if (debug) std::clog << std::endl;
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..6fce45f
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+backport
diff --git a/debian/rules b/debian/rules
index c819273..31da13a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,6 @@
#!/usr/bin/make -f
+
+export CXX=g++-4.7
+
%:
dh $@ --with bash-completion --parallel
diff --git a/debian/ssh-agent-filter.lintian-overrides b/debian/ssh-agent-filter.lintian-overrides
new file mode 100644
index 0000000..b7b1793
--- /dev/null
+++ b/debian/ssh-agent-filter.lintian-overrides
@@ -0,0 +1,2 @@
+# wheezy has old pandoc
+hyphen-used-as-minus-sign