summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-11-17 14:05:54 +0100
committerTimo Weingärtner <timo@tiwe.de>2013-11-17 14:11:09 +0100
commit9933463097df9fe16e446a0744204dbe04223544 (patch)
treee4888e1d19766654be66b0d7b8fe994255eea47e
parentd34f4e8e84f3c503a830d1495945f8c4da7c4abe (diff)
downloadhadori-9933463097df9fe16e446a0744204dbe04223544.tar.gz
use LDLIBS instead of LDFLAGS
LDLIBS are put behind the prerequisites by make's built-in rules so linking won't fail with --as-needed.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dbf5ab6..b3cbd47 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@
# You should have received a copy of the GNU General Public License
# along with hadori. If not, see <http://www.gnu.org/licenses/>.
-LDFLAGS+=-lboost_program_options
+LDLIBS=-lboost_program_options
CXXFLAGS?=-O2 -Wall
CXXFLAGS+=-std=c++0x
CPPFLAGS+=-D_FILE_OFFSET_BITS=64