summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2012-02-03 13:52:04 +0100
committerTimo Weingärtner <timo@tiwe.de>2012-02-03 13:54:17 +0100
commit894df89979fdd604588eae999f984b05e471ceb8 (patch)
tree4c60e8034b556e96348e2ce67bee92a4ce349771
parentcee77d8be37b074fd6e039a8207e30f2f067c561 (diff)
downloadhadori-894df89979fdd604588eae999f984b05e471ceb8.tar.gz
Output help to stdout and exit with EX_OK.
-rw-r--r--Makefile2
-rw-r--r--hadori.C6
2 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index cd5a797..997168f 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,7 @@ CPPFLAGS+=-D_FILE_OFFSET_BITS=64
all: hadori
hadori.1: hadori
- help2man -n $< -o $@ -N --no-discard-stderr --version-string 0.1 ./$<
+ help2man -n $< -o $@ -N --version-string 0.1 ./$<
hadori: hadori.o
hadori.o: hadori.C inode.h
diff --git a/hadori.C b/hadori.C
index 1b12de4..f462d66 100644
--- a/hadori.C
+++ b/hadori.C
@@ -206,9 +206,9 @@ int main (int const argc, char ** argv) {
po::notify(config);
if (config.count("help")) {
- error << "Invocation: hadori [ OPTIONS ] [ ARGUMENTS ]" << std::endl;
- error << opts << std::endl;
- return EX_USAGE;
+ std::cout << "Invocation: hadori [ OPTIONS ] [ ARGUMENTS ]" << std::endl;
+ std::cout << opts << std::endl;
+ return EX_OK;
}
if (not config.count("debug"))