aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 368c4dc..7e82b15 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,10 @@ CXXFLAGS ?= -g -O2 -Wall -Wold-style-cast
CXXFLAGS += -std=c++11
LDFLAGS += -lboost_program_options -lboost_filesystem -lboost_system -lnettle
-all: ssh-agent-filter.1
+all: ssh-agent-filter.1 afssh.1
+
+%.1: %.1.md
+ pandoc -s -w man $< -o $@
ssh-agent-filter.1: ssh-agent-filter
help2man -n $< -o $@ -N ./$<
@@ -34,6 +37,6 @@ version.h:
test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@
clean:
- $(RM) ssh-agent-filter.1 ssh-agent-filter *.o
+ $(RM) *.1 ssh-agent-filter *.o
.PHONY: version.h