aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2015-08-28 19:12:58 +0200
committerTimo Weingärtner <timo@tiwe.de>2015-08-28 19:27:48 +0200
commit774ff2757de2a32c57046cbdc8425c6c22759035 (patch)
tree2237daf46ad600e8439bedd8f4eb60fbcffaa038
parentd9ffc789b1c7e781acbdd8310aef871dc3a41c13 (diff)
downloadssh-agent-filter-774ff2757de2a32c57046cbdc8425c6c22759035.tar.gz
rename C++ header to .H
-rw-r--r--Makefile6
-rw-r--r--rfc4251.C2
-rw-r--r--rfc4251.H (renamed from rfc4251.h)0
-rw-r--r--rfc4251_gmp.C2
-rw-r--r--ssh-agent-filter.C2
5 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index fcecbaa..3b3002b 100644
--- a/Makefile
+++ b/Makefile
@@ -32,9 +32,9 @@ ssh-agent-filter.1: ssh-agent-filter
ssh-agent-filter: ssh-agent-filter.o
-ssh-agent-filter.o: ssh-agent-filter.C rfc4251.h ssh-agent.h version.h
-rfc4251.o: rfc4251.C rfc4251.h
-rfc4251_gmp.o: rfc4251_gmp.C rfc4251.h
+ssh-agent-filter.o: ssh-agent-filter.C rfc4251.H ssh-agent.h version.h
+rfc4251.o: rfc4251.C rfc4251.H
+rfc4251_gmp.o: rfc4251_gmp.C rfc4251.H
version.h:
test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@
diff --git a/rfc4251.C b/rfc4251.C
index 8ca5f2b..0b7aa62 100644
--- a/rfc4251.C
+++ b/rfc4251.C
@@ -22,7 +22,7 @@
* along with ssh-agent-filter. If not, see <http://www.gnu.org/licenses/>.
*/
-#include "rfc4251.h"
+#include "rfc4251.H"
rfc4251string::rfc4251string (std::vector<std::string> const & v) {
for (auto it = v.begin(); it != v.end();) {
diff --git a/rfc4251.h b/rfc4251.H
index d9ac93e..d9ac93e 100644
--- a/rfc4251.h
+++ b/rfc4251.H
diff --git a/rfc4251_gmp.C b/rfc4251_gmp.C
index d3a664e..db46429 100644
--- a/rfc4251_gmp.C
+++ b/rfc4251_gmp.C
@@ -21,7 +21,7 @@
* along with ssh-agent-filter. If not, see <http://www.gnu.org/licenses/>.
*/
-#include "rfc4251.h"
+#include "rfc4251.H"
rfc4251string::rfc4251string (mpz_srcptr x) {
if (mpz_sgn(x) == 0)
diff --git a/ssh-agent-filter.C b/ssh-agent-filter.C
index faa31f9..2b6df6f 100644
--- a/ssh-agent-filter.C
+++ b/ssh-agent-filter.C
@@ -83,7 +83,7 @@ using std::lock_guard;
#include <nettle/base64.h>
#include <nettle/base16.h>
-#include "rfc4251.h"
+#include "rfc4251.H"
#include "ssh-agent.h"
#include "version.h"