aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2015-09-06 17:01:47 +0200
committerTimo Weingärtner <timo@tiwe.de>2015-09-06 17:06:05 +0200
commit33485a9d38ad40ee971695384cfc869ced281a8c (patch)
tree9c5f26652ab14dd94fa407ad22f160e2f5e95f6a
parentad1c2d2b28209654b447e1a5198c6516cfa50b88 (diff)
downloadssh-agent-filter-33485a9d38ad40ee971695384cfc869ced281a8c.tar.gz
Makefile: link to pthread
some versions of gcc reference a pthread function in the <thread> header
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3b3002b..2f26553 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ CXXFLAGS ?= -g -O2 -Wall -Wold-style-cast
CPPFLAGS += -D_FILE_OFFSET_BITS=64
CXXFLAGS += -std=c++11
-LDLIBS = -lstdc++ -lboost_program_options -lboost_filesystem -lboost_system -lboost_iostreams -lnettle
+LDLIBS = -lstdc++ -lboost_program_options -lboost_filesystem -lboost_system -lboost_iostreams -lnettle -lpthread
all: ssh-agent-filter.1 afssh.1 ssh-askpass-noinput.1