aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-11-13 23:42:46 +0100
committerTimo Weingärtner <timo@tiwe.de>2013-11-13 23:42:46 +0100
commita8c1ef855655e7419e54317a8e782f3993d99f7d (patch)
tree24fa186c7718ddc7a36b662ef86b1aa682b542e3
parenta42c87e6a761a56ebc63cd7728fa2126b2e8805f (diff)
downloadssh-agent-filter-a8c1ef855655e7419e54317a8e782f3993d99f7d.tar.gz
use LDLIBS instead of LDFLAGS
LDLIBS are put behind the prerequisites by make's built-in rules so linking won't fail with --as-needed.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d929b6c..378c33d 100644
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,7 @@
CXXFLAGS ?= -g -O2 -Wall -Wold-style-cast
CXXFLAGS += -std=c++11
-LDFLAGS += -lstdc++ -lboost_program_options -lboost_filesystem -lboost_system -lboost_iostreams -lnettle
+LDLIBS = -lstdc++ -lboost_program_options -lboost_filesystem -lboost_system -lboost_iostreams -lnettle
all: ssh-agent-filter.1 afssh.1 ssh-askpass-noinput.1