aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-07-01 16:04:04 +0200
committerTimo Weingärtner <timo@tiwe.de>2013-07-01 18:16:21 +0200
commit23f63eb81167afaa14ecfbbfd30c106b70659fe5 (patch)
tree582d4c3e6d6f5d561d9fadfa13e69d946eb8070c
parentf35640624b3e02bd259533bdf453f55e003ee76b (diff)
downloadssh-agent-filter-23f63eb81167afaa14ecfbbfd30c106b70659fe5.tar.gz
add manpage for afssh(1)
using pandoc to generate groff from markdown
-rw-r--r--Makefile7
-rw-r--r--afssh.1.md38
2 files changed, 43 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 368c4dc..7e82b15 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,10 @@ CXXFLAGS ?= -g -O2 -Wall -Wold-style-cast
CXXFLAGS += -std=c++11
LDFLAGS += -lboost_program_options -lboost_filesystem -lboost_system -lnettle
-all: ssh-agent-filter.1
+all: ssh-agent-filter.1 afssh.1
+
+%.1: %.1.md
+ pandoc -s -w man $< -o $@
ssh-agent-filter.1: ssh-agent-filter
help2man -n $< -o $@ -N ./$<
@@ -34,6 +37,6 @@ version.h:
test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@
clean:
- $(RM) ssh-agent-filter.1 ssh-agent-filter *.o
+ $(RM) *.1 ssh-agent-filter *.o
.PHONY: version.h
diff --git a/afssh.1.md b/afssh.1.md
new file mode 100644
index 0000000..5d17d2e
--- /dev/null
+++ b/afssh.1.md
@@ -0,0 +1,38 @@
+% AFSSH(1)
+% Timo Weingärtner <timo@tiwe.de>
+% 2013-07-01
+
+# NAME
+
+afssh - wrapper around ssh-agent-filter and ssh
+
+# SYNOPSIS
+
+*afssh* [*ssh-agent-filter options*] -- [*ssh arguments*]
+
+*afssh* -- [*ssh arguments*]
+
+# DESCRIPTION
+
+afssh (agent filtered ssh) start ssh-agent-filter(1), passing it the arguments given to afssh before the separator `--`.
+If there are no arguments before `--`, whiptail(1) or dialog(1) is used to ask the user which keys to forward.
+
+After setting up the ssh-agent-filter(1) ssh(1) is started with `-A` and the rest of the arguments (after `--`).
+
+When ssh(1) exits, the ssh-agent-filter(1) is killed to not leave tons of them
+
+# OPTIONS
+
+-h, \--help
+: prints a short usage description, then runs ssh-agent-filter(1) with `--help` and ssh(1) with `--help`
+
+\--
+: mandatory separator between the options passed to ssh-agent-filter(1) and those passed to ssh(1)
+
+# RETURN VALUES
+
+Returns the return value of ssh(1) unless setting up the ssh-agent-filter failed, in which case the return value might be any non-zero value.
+
+# SEE ALSO
+
+ssh-agent-filter(1), ssh(1), ssh-agent(1), ssh-add(1), whiptail(1), dialog(1)