aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Norris <adric@debian.org>2005-11-16 07:56:25 -0600
committerTimo Weingärtner <timo@tiwe.de>2012-11-08 08:21:37 +0100
commit6b54c9a80f45d5ef85d4cf6c1bb5291670324932 (patch)
tree78b1cf9f9d81d8e5ff3217fe552b6f8932f875f8
parenta5e39be83fdda78550b960b6099e48f60ac6305c (diff)
downloadlibpam-pwdfile-6b54c9a80f45d5ef85d4cf6c1bb5291670324932.tar.gz
Imported Debian patch 0.99-3debian/0.99-3
-rw-r--r--debian/README.Debian29
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules6
4 files changed, 30 insertions, 14 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index be39559..34d3253 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -1,16 +1,25 @@
libpam-pwdfile for Debian
-------------------------
-This module allows one to authenticate users using a passwd-like file.
-Creating this file currently means either copying the relevant entries from
-/etc/{passwd,shadow}, or using the chpwdfile utility (not yet packaged) from
-http://eclipse.che.uct.ac.za/chpwdfile/.
+This module allows one to authenticate users via an arbitrary password file.
+The file follows the same format as /etc/passwd and /etc/shadow, although only
+the first two fields are required. In other words, each entry should start at
+the beginning of a line and use the following format:
-Below is an example of a working /etc/pam.d/* configuration... specifically,
-this is copy of my /etc/pam.d/qpopper. Please note that the "account" entry
-is required.
+ [username]:[password-hash]
- auth required pam_pwdfile.so pwdfile /etc/qpopper/qpopper.pwd
- account required pam_unix_acct.so
- -- Greg Norris <adric@debian.org>, Tue, 08 Jul 2003 18:57:16 -0500
+The following command provides a quick way to generate an appropriate hash,
+which may then be copied into your password file.
+
+ perl -e '$salt=q($1$).int(rand(1e8)); print "password: "; chomp($passwd=<STDIN>); print crypt($passwd,$salt),"\n"'
+
+
+Here's an example of a working configuration... specifically, this is copied
+from my /etc/pam.d/dovecot file.
+
+ auth required pam_pwdfile.so pwdfile=/etc/dovecot/dovecot.passwd
+ @include common-account
+ @include common-session
+
+ -- Greg Norris <adric@debian.org> Wed, 16 Nov 2005 07:50:37 -0600
diff --git a/debian/changelog b/debian/changelog
index c970a4d..e5cc4ba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libpam-pwdfile (0.99-3) unstable; urgency=low
+
+ * Update doeumentation in README.Debian
+ * Updated to policy version 3.6.2 (no changes required)
+
+ -- Greg Norris <adric@debian.org> Wed, 16 Nov 2005 07:56:25 -0600
+
libpam-pwdfile (0.99-2) unstable; urgency=low
* Include contrib/warwick_duncan-cyrus_without_system_accounts.txt under
diff --git a/debian/control b/debian/control
index 30f0398..7e65b24 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: libpam-pwdfile
Section: admin
Priority: extra
Maintainer: Greg Norris <adric@debian.org>
-Standards-Version: 3.5.10
+Standards-Version: 3.6.2
Build-Depends: debhelper, libpam0g-dev
Package: libpam-pwdfile
diff --git a/debian/rules b/debian/rules
index 57b4e85..b0cbb7f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@
#export DH_VERBOSE=1
# This is the debhelper compatability version to use.
-export DH_COMPAT=1
+export DH_COMPAT=4
export PACKAGE=pam_pwdfile
@@ -35,7 +35,7 @@ install: build
dh_clean -k
dh_installdirs
- $(MAKE) -f Makefile.Debian DESTDIR=$(CURDIR)/debian/tmp install
+ $(MAKE) -f Makefile.Debian DESTDIR=$(CURDIR)/debian/`dh_listpackages` install
touch install-stamp
@@ -56,7 +56,7 @@ binary-arch: build install
# dh_installpam
# dh_installinit
# dh_installcron
- dh_installmanpages
+ dh_installman
# dh_installinfo
# dh_undocumented
dh_installchangelogs changelog