aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Palfrader <weasel@debian.org>2008-09-25 12:50:11 +0200
committerTimo Weingärtner <timo@tiwe.de>2012-11-08 08:21:42 +0100
commit40f13ce64b7e5f80dea6c7e165bb6163f3e32cae (patch)
tree85894f2e2753c4ae842ec4731ce7cb86ec5ed7e6
parent6b54c9a80f45d5ef85d4cf6c1bb5291670324932 (diff)
downloadlibpam-pwdfile-40f13ce64b7e5f80dea6c7e165bb6163f3e32cae.tar.gz
Imported Debian patch 0.99-3.1debian/0.99-3.1
-rw-r--r--Makefile.Debian6
-rw-r--r--debian/changelog9
-rw-r--r--pam_pwdfile.c2
3 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.Debian b/Makefile.Debian
index 2b9e302..597c53a 100644
--- a/Makefile.Debian
+++ b/Makefile.Debian
@@ -3,9 +3,9 @@
TITLE=pam_pwdfile
CC = gcc
-LD = ld
-CFLAGS = -fPIC -c -g -Wall -Wformat-security
-LDFLAGS = -x --shared
+LD = gcc
+CFLAGS = -fPIC -c -g -Wall -Wformat-security -fvisibility=hidden
+LDFLAGS = -Wl,-x --shared
LDLIBS = -lcrypt -lpam -lpam_misc
LIBSRC = $(TITLE).c
LIBOBJ = $(TITLE).o md5_good.o md5_broken.o md5_crypt_good.o md5_crypt_broken.o bigcrypt.o
diff --git a/debian/changelog b/debian/changelog
index e5cc4ba..da5f962 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+libpam-pwdfile (0.99-3.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Link using gcc instead of ld (closes: #499203).
+ * Mark the pam_sm_* functions as __attribute__((visibility("default"))) and
+ build with -fvisibility=hidden.
+
+ -- Peter Palfrader <weasel@debian.org> Thu, 25 Sep 2008 12:50:11 +0200
+
libpam-pwdfile (0.99-3) unstable; urgency=low
* Update doeumentation in README.Debian
diff --git a/pam_pwdfile.c b/pam_pwdfile.c
index ec2bd96..be6e6ad 100644
--- a/pam_pwdfile.c
+++ b/pam_pwdfile.c
@@ -222,6 +222,7 @@ static int fgetpwnam(FILE *stream, const char *name, char *password) {
}
/* expected hook for auth service */
+__attribute__((visibility("default")))
PAM_EXTERN int pam_sm_authenticate(pam_handle_t *pamh, int flags,
int argc, const char **argv) {
int retval, pcnt, pwdfilename_found;
@@ -408,6 +409,7 @@ PAM_EXTERN int pam_sm_authenticate(pam_handle_t *pamh, int flags,
}
/* another expected hook */
+__attribute__((visibility("default")))
PAM_EXTERN int pam_sm_setcred(pam_handle_t *pamh, int flags,
int argc, const char **argv)
{