aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-05-28 19:28:27 +0200
committerTimo Weingärtner <timo@tiwe.de>2013-05-29 01:15:44 +0200
commit181e4c06c36c05a87b3eda05834085e30328479b (patch)
treeb922d5e63957001bf1dcdcf9505e89c991db92d0
parentc7344fa5ca42b3203ce7fc2ff8cb93b42bf78123 (diff)
downloadlibpam-pwdfile-181e4c06c36c05a87b3eda05834085e30328479b.tar.gz
drop stuff in debian/ not needed anymore
patches Makefile README.Debian source.lintian-overrides Git-Dch: Full
-rw-r--r--debian/Makefile39
-rw-r--r--debian/README.Debian25
-rwxr-xr-xdebian/libpam-pwdfile.dirs2
-rw-r--r--debian/libpam-pwdfile.docs1
-rw-r--r--debian/patches/regular_crypt22
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/visibility23
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/source.lintian-overrides3
9 files changed, 0 insertions, 123 deletions
diff --git a/debian/Makefile b/debian/Makefile
deleted file mode 100644
index 965cf9d..0000000
--- a/debian/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# Modified Makefile to allow for building of the standalone module
-
-TITLE=pam_pwdfile
-
-CC = gcc
-LD = gcc
-CFLAGS += -fPIC -c -g -Wall -Wformat-security -fvisibility=hidden
-LDFLAGS += -Wl,-x --shared
-LDLIBS = -lcrypt -lpam
-LIBOBJ = $(TITLE).o md5_good.o md5_broken.o md5_crypt_good.o md5_crypt_broken.o bigcrypt.o
-LIBSHARED = $(TITLE).so
-
-all: $(LIBSHARED)
-
-md5_good.o: md5.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -DHIGHFIRST -D'MD5Name(x)=Good##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_broken.o: md5.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Broken##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_crypt_good.o: md5_crypt.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Good##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_crypt_broken.o: md5_crypt.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Broken##x' \
- $(TARGET_ARCH) $< -o $@
-
-$(LIBSHARED): $(LIBOBJ)
- $(LD) $(LDFLAGS) -o $@ $(LIBOBJ) $(LDLIBS)
-
-clean:
- rm -f $(LIBOBJS) $(LIBSHARED) core *~
-
-extraclean: clean
- rm -f *.a *.o *.so *.bak
-
diff --git a/debian/README.Debian b/debian/README.Debian
deleted file mode 100644
index 34d3253..0000000
--- a/debian/README.Debian
+++ /dev/null
@@ -1,25 +0,0 @@
-libpam-pwdfile for Debian
--------------------------
-
-This module allows one to authenticate users via an arbitrary password file.
-The file follows the same format as /etc/passwd and /etc/shadow, although only
-the first two fields are required. In other words, each entry should start at
-the beginning of a line and use the following format:
-
- [username]:[password-hash]
-
-
-The following command provides a quick way to generate an appropriate hash,
-which may then be copied into your password file.
-
- perl -e '$salt=q($1$).int(rand(1e8)); print "password: "; chomp($passwd=<STDIN>); print crypt($passwd,$salt),"\n"'
-
-
-Here's an example of a working configuration... specifically, this is copied
-from my /etc/pam.d/dovecot file.
-
- auth required pam_pwdfile.so pwdfile=/etc/dovecot/dovecot.passwd
- @include common-account
- @include common-session
-
- -- Greg Norris <adric@debian.org> Wed, 16 Nov 2005 07:50:37 -0600
diff --git a/debian/libpam-pwdfile.dirs b/debian/libpam-pwdfile.dirs
deleted file mode 100755
index 5cd1ce0..0000000
--- a/debian/libpam-pwdfile.dirs
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/usr/bin/dh-exec
-lib/${DEB_HOST_MULTIARCH}/security
diff --git a/debian/libpam-pwdfile.docs b/debian/libpam-pwdfile.docs
index 5c130d3..e845566 100644
--- a/debian/libpam-pwdfile.docs
+++ b/debian/libpam-pwdfile.docs
@@ -1,2 +1 @@
README
-contrib/warwick_duncan-cyrus_without_system_accounts.txt
diff --git a/debian/patches/regular_crypt b/debian/patches/regular_crypt
deleted file mode 100644
index 9895e33..0000000
--- a/debian/patches/regular_crypt
+++ /dev/null
@@ -1,22 +0,0 @@
-Description: Use libc's crypt in the regular way
- * That should support newer crypt types.
- * We do the check before the weird stuff but keep it to not break setups
- using broken md5 hashing or bigcrypt.
- * CRYPTED_BCPWD_LEN as an upper limit seems to be ok by now.
-Author: Timo Weingärtner <timo@tiwe.de>
-Forwarded: no
-Last-Update: 2012-06-20
-
---- libpam-pwdfile-0.99.orig/pam_pwdfile.c
-+++ libpam-pwdfile-0.99/pam_pwdfile.c
-@@ -348,6 +348,10 @@ PAM_EXTERN int pam_sm_authenticate(pam_h
-
- temp_result = 0;
-
-+ if (strcmp(crypt(password, stored_crypted_password), stored_crypted_password) == 0) {
-+ D(_pam_log(LOG_ERR,"password matched using the systems crypt()"));
-+ temp_result = 1;
-+ }
- /* Extract the salt and set the passwd length, depending on MD5 or DES */
- if (strncmp(stored_crypted_password, "$1$", 3) == 0) {
- D(_pam_log(LOG_ERR,"password hash type is 'md5'"));
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index fb3fb12..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,2 +0,0 @@
-visibility
-regular_crypt
diff --git a/debian/patches/visibility b/debian/patches/visibility
deleted file mode 100644
index d121a1e..0000000
--- a/debian/patches/visibility
+++ /dev/null
@@ -1,23 +0,0 @@
-Description: Mark the pam_sm_* functions as __attribute__((visibility("default")))
-Author: Peter Palfrader <weasel@debian.org>
-Bug-Debian: http://bugs.debian.org/499203
-Last-Update: 2012-06-20
-
---- libpam-pwdfile-0.99.orig/pam_pwdfile.c
-+++ libpam-pwdfile-0.99/pam_pwdfile.c
-@@ -222,6 +222,7 @@
- }
-
- /* expected hook for auth service */
-+__attribute__((visibility("default")))
- PAM_EXTERN int pam_sm_authenticate(pam_handle_t *pamh, int flags,
- int argc, const char **argv) {
- int retval, pcnt, pwdfilename_found;
-@@ -408,6 +409,7 @@
- }
-
- /* another expected hook */
-+__attribute__((visibility("default")))
- PAM_EXTERN int pam_sm_setcred(pam_handle_t *pamh, int flags,
- int argc, const char **argv)
- {
diff --git a/debian/rules b/debian/rules
index 9546ad8..c34429d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,10 +3,4 @@
%:
dh $@
-override_dh_auto_build:
- $(MAKE) -f debian/Makefile
-
-override_dh_auto_clean:
- $(MAKE) -f debian/Makefile extraclean
-
override_dh_auto_install:
diff --git a/debian/source.lintian-overrides b/debian/source.lintian-overrides
deleted file mode 100644
index 0cd63ff..0000000
--- a/debian/source.lintian-overrides
+++ /dev/null
@@ -1,3 +0,0 @@
-# already in upstream tarball
-source-contains-cvs-control-dir contrib/CVS
-source-contains-cvs-control-dir CVS