aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b2e05ec..9e112a3 100644
--- a/Makefile
+++ b/Makefile
@@ -36,6 +36,9 @@ ssh-agent-filter.o: ssh-agent-filter.C rfc4251.H ssh-agent.h version.h
rfc4251.o: rfc4251.C rfc4251.H
rfc4251_gmp.o: rfc4251_gmp.C rfc4251.H
+test:
+ PATH="$$(pwd):$$PATH" ./tests
+
version.h:
test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@