aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2018-01-08 20:44:32 +0100
committerTimo Weingärtner <timo@tiwe.de>2018-01-09 22:04:08 +0100
commitbae7e0329adf50af874bf323cefc9e54c2cd00a0 (patch)
treeb3a37fce32088c47f97b2cf79abe36c3e41537a7 /Makefile
parentc97c3087ad393eef928f961869b0c5e400f8a66f (diff)
downloadssh-agent-filter-bae7e0329adf50af874bf323cefc9e54c2cd00a0.tar.gz
add tests using shunit2
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b2e05ec..9e112a3 100644
--- a/Makefile
+++ b/Makefile
@@ -36,6 +36,9 @@ ssh-agent-filter.o: ssh-agent-filter.C rfc4251.H ssh-agent.h version.h
rfc4251.o: rfc4251.C rfc4251.H
rfc4251_gmp.o: rfc4251_gmp.C rfc4251.H
+test:
+ PATH="$$(pwd):$$PATH" ./tests
+
version.h:
test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@