aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-06-17 20:33:38 +0200
committerTimo Weingärtner <timo@tiwe.de>2013-06-17 20:33:38 +0200
commit7ed93d297cda37e9f0e89a54ab270d73e3cb4f3c (patch)
treef41e113acf5722c8479059cde81284ae9502b738 /Makefile
downloadssh-agent-filter-7ed93d297cda37e9f0e89a54ab270d73e3cb4f3c.tar.gz
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..368c4dc
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,39 @@
+# Copyright (C) 2013 Timo Weingärtner <timo@tiwe.de>
+#
+# This file is part of ssh-agent-filter.
+#
+# ssh-agent-filter is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# ssh-agent-filter is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ssh-agent-filter. If not, see <http://www.gnu.org/licenses/>.
+
+
+CXXFLAGS ?= -g -O2 -Wall -Wold-style-cast
+
+CXXFLAGS += -std=c++11
+LDFLAGS += -lboost_program_options -lboost_filesystem -lboost_system -lnettle
+
+all: ssh-agent-filter.1
+
+ssh-agent-filter.1: ssh-agent-filter
+ help2man -n $< -o $@ -N ./$<
+
+ssh-agent-filter: ssh-agent-filter.o
+
+ssh-agent-filter.o: ssh-agent-filter.C rfc4251.h ssh-agent.h version.h
+
+version.h:
+ test ! -d .git || git describe | sed 's/^.*$$/#define SSH_AGENT_FILTER_VERSION "ssh-agent-filter \0"/' > $@
+
+clean:
+ $(RM) ssh-agent-filter.1 ssh-agent-filter *.o
+
+.PHONY: version.h