summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2014-02-18 18:25:08 +0100
committerTimo Weingärtner <timo@tiwe.de>2014-02-18 18:30:01 +0100
commitf8b47031fd65b9055e6a89a961466bdb367cd710 (patch)
treed441d5fcf784e4ad901918657b94552a4f5403b7 /Makefile
parentc4c47613070b81b95434b03b6cda74daa76aada6 (diff)
downloadopenssh-known-hosts-f8b47031fd65b9055e6a89a961466bdb367cd710.tar.gz
Documentation update, license clarification
use pandoc for manpage generation, drop now-redundant README
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..4c75e26
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+# Copyright (C) 2014 Timo Weingärtner <timo@tiwe.de>
+#
+# This file is part of openssh-known-hosts.
+#
+# openssh-known-hosts is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# openssh-known-hosts is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with openssh-known-hosts. If not, see <http://www.gnu.org/licenses/>.
+
+all: update-openssh-known-hosts.8
+
+%.8: %.8.md
+ pandoc -s -w man $< -o $@
+
+clean:
+ $(RM) *.8