summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2012-02-25 21:17:06 +0100
committerTimo Weingärtner <timo@tiwe.de>2012-02-25 21:17:06 +0100
commita2060472fe74355a4b772ca0efd28249702a7025 (patch)
treecc3010e8cec7cca8156034a25cb5f18432ea08b5
parente5b99e36d96614d059137f3df323bcc39ead369e (diff)
downloadopenssh-known-hosts-a2060472fe74355a4b772ca0efd28249702a7025.tar.gz
Imported Debian version 0.5debian/0.5
-rw-r--r--debian/changelog6
-rwxr-xr-xupdate-openssh-known-hosts6
2 files changed, 9 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 7791a73..180fa1b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+openssh-known-hosts (0.5) fsmi-squeeze; urgency=low
+
+ * Fix fd redirection (Errors went into ssh_known_hosts).
+
+ -- Timo Weingärtner <timo@tiwe.de> Sat, 10 Jul 2010 18:51:56 +0200
+
openssh-known-hosts (0.4) fsmi-squeeze; urgency=low
* Don't update ssh_known_hosts if nothing changed.
diff --git a/update-openssh-known-hosts b/update-openssh-known-hosts
index 00d74a6..bf5981b 100755
--- a/update-openssh-known-hosts
+++ b/update-openssh-known-hosts
@@ -76,15 +76,15 @@ run-parts --list "${CONFDIR}/sources/" | while read sourcefile; do
if [ "$fail" = "1" ]; then
exit 1
fi
- }
+ } >&2
) || exit 1
if [ -e ${source}/new ]; then
mv ${source}/new ${source}/current
fi
if [ -e ${source}/current ]; then
- cat ${source}/current >&3
+ sort -u ${source}/current >&3
fi
-done 3>&1 | sort -u >| "${OUTFILE}.new"
+done 3>| "${OUTFILE}.new"
if cmp -s "${OUTFILE}" "${OUTFILE}.new"; then
rm "${OUTFILE}.new"