aboutsummaryrefslogtreecommitdiff
path: root/debian/Makefile
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2013-05-28 19:28:27 +0200
committerTimo Weingärtner <timo@tiwe.de>2013-05-29 01:15:44 +0200
commit181e4c06c36c05a87b3eda05834085e30328479b (patch)
treeb922d5e63957001bf1dcdcf9505e89c991db92d0 /debian/Makefile
parentc7344fa5ca42b3203ce7fc2ff8cb93b42bf78123 (diff)
downloadlibpam-pwdfile-181e4c06c36c05a87b3eda05834085e30328479b.tar.gz
drop stuff in debian/ not needed anymore
patches Makefile README.Debian source.lintian-overrides Git-Dch: Full
Diffstat (limited to 'debian/Makefile')
-rw-r--r--debian/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/debian/Makefile b/debian/Makefile
deleted file mode 100644
index 965cf9d..0000000
--- a/debian/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# Modified Makefile to allow for building of the standalone module
-
-TITLE=pam_pwdfile
-
-CC = gcc
-LD = gcc
-CFLAGS += -fPIC -c -g -Wall -Wformat-security -fvisibility=hidden
-LDFLAGS += -Wl,-x --shared
-LDLIBS = -lcrypt -lpam
-LIBOBJ = $(TITLE).o md5_good.o md5_broken.o md5_crypt_good.o md5_crypt_broken.o bigcrypt.o
-LIBSHARED = $(TITLE).so
-
-all: $(LIBSHARED)
-
-md5_good.o: md5.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -DHIGHFIRST -D'MD5Name(x)=Good##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_broken.o: md5.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Broken##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_crypt_good.o: md5_crypt.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Good##x' \
- $(TARGET_ARCH) $< -o $@
-
-md5_crypt_broken.o: md5_crypt.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -D'MD5Name(x)=Broken##x' \
- $(TARGET_ARCH) $< -o $@
-
-$(LIBSHARED): $(LIBOBJ)
- $(LD) $(LDFLAGS) -o $@ $(LIBOBJ) $(LDLIBS)
-
-clean:
- rm -f $(LIBOBJS) $(LIBSHARED) core *~
-
-extraclean: clean
- rm -f *.a *.o *.so *.bak
-