summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 546e266..a55a9dd 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ hadori: hadori.o
hadori.o: hadori.C inode.h version.h
version.h:
- test -d .git && git describe | sed 's/^\(.*\)$$/#define HADORI_VERSION "hadori \1"/' > $@
+ test ! -d .git || git describe | sed 's/^\(.*\)$$/#define HADORI_VERSION "hadori \1"/' > $@
clean:
rm -f hadori hadori.o hadori.1