summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTimo Weingärtner <timo@tiwe.de>2012-02-03 14:33:21 +0100
committerTimo Weingärtner <timo@tiwe.de>2012-02-15 02:07:51 +0100
commit27b8fc1395bece0dc309512a3790a4892e0d29b1 (patch)
tree355770e76754b9029c606469522cf0b56d08a976 /Makefile
parent894df89979fdd604588eae999f984b05e471ceb8 (diff)
downloadhadori-27b8fc1395bece0dc309512a3790a4892e0d29b1.tar.gz
Add --version, generate version.h from git, clean manpage
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 997168f..546e266 100644
--- a/Makefile
+++ b/Makefile
@@ -20,13 +20,18 @@ CXXFLAGS?=-O2 -Wall
CXXFLAGS+=-std=c++0x
CPPFLAGS+=-D_FILE_OFFSET_BITS=64
-all: hadori
+all: hadori.1
hadori.1: hadori
- help2man -n $< -o $@ -N --version-string 0.1 ./$<
+ help2man -n $< -o $@ -N ./$<
hadori: hadori.o
-hadori.o: hadori.C inode.h
+hadori.o: hadori.C inode.h version.h
+
+version.h:
+ test -d .git && git describe | sed 's/^\(.*\)$$/#define HADORI_VERSION "hadori \1"/' > $@
clean:
- rm -f hadori hadori.o
+ rm -f hadori hadori.o hadori.1
+
+.PHONY: version.h clean