diff options
author | Timo Weingärtner <timo@tiwe.de> | 2012-02-26 16:13:50 +0100 |
---|---|---|
committer | Timo Weingärtner <timo@tiwe.de> | 2012-02-26 16:13:50 +0100 |
commit | 59496322885806e9c9f82c122a1dc2b6d4f5804c (patch) | |
tree | 48a383048784359ce7fe697e37438f144e039d01 /Makefile | |
parent | bccb1f0a382195d64d7691f8f464811a7cb58cb6 (diff) | |
parent | fc2e6f497641f6189d4c46bb975c47fe5cdecc24 (diff) | |
download | hadori-59496322885806e9c9f82c122a1dc2b6d4f5804c.tar.gz |
Merge branch 'master' into debian
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 30 |
1 files changed, 26 insertions, 4 deletions
@@ -1,15 +1,37 @@ +# Copyright (C) 2011 Timo Weingärtner <timo@tiwe.de> +# +# This file is part of hadori. +# +# hadori is free software: you can redistribute it and/or modify +# it under the terms of the GNU General Public License as published by +# the Free Software Foundation, either version 3 of the License, or +# (at your option) any later version. +# +# Foobar is distributed in the hope that it will be useful, +# but WITHOUT ANY WARRANTY; without even the implied warranty of +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the +# GNU General Public License for more details. +# +# You should have received a copy of the GNU General Public License +# along with hadori. If not, see <http://www.gnu.org/licenses/>. + LDFLAGS+=-lz -lboost_program_options CXXFLAGS?=-O2 -Wall CXXFLAGS+=-std=c++0x CPPFLAGS+=-D_FILE_OFFSET_BITS=64 -all: hadori +all: hadori.1 hadori.1: hadori - help2man -n $< -o $@ -N --no-discard-stderr --version-string 0.1 ./$< + help2man -n $< -o $@ -N ./$< hadori: hadori.o -hadori.o: hadori.C inode.h +hadori.o: hadori.C inode.h version.h + +version.h: + test ! -d .git || git describe | sed 's/^\(.*\)$$/#define HADORI_VERSION "hadori \1"/' > $@ clean: - rm -f hadori hadori.o + rm -f hadori hadori.o hadori.1 + +.PHONY: version.h clean |