diff options
author | Timo Weingärtner <timo@tiwe.de> | 2017-04-30 13:49:21 +0200 |
---|---|---|
committer | Timo Weingärtner <timo@tiwe.de> | 2017-04-30 13:49:21 +0200 |
commit | 1fcd6de354c34312f2ed787f214e3563b6717a0e (patch) | |
tree | 85b2bd58e26741855604a69e4eacc07e05c207a6 /Makefile | |
parent | 03004e76778d9c9239c6d16c3181849b71865c5c (diff) | |
parent | a987b5383931dd4735a3f7e2261e9a809543b22a (diff) | |
download | hadori-1fcd6de354c34312f2ed787f214e3563b6717a0e.tar.gz |
Merge tag '1.0' into debian
1.0
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -7,7 +7,7 @@ # the Free Software Foundation, either version 3 of the License, or # (at your option) any later version. # -# Foobar is distributed in the hope that it will be useful, +# hadori is distributed in the hope that it will be useful, # but WITHOUT ANY WARRANTY; without even the implied warranty of # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the # GNU General Public License for more details. @@ -15,9 +15,9 @@ # You should have received a copy of the GNU General Public License # along with hadori. If not, see <http://www.gnu.org/licenses/>. -LDFLAGS+=-lz -lboost_program_options +LDLIBS=-lboost_program_options -lstdc++ CXXFLAGS?=-O2 -Wall -CXXFLAGS+=-std=c++0x +CXXFLAGS+=-std=c++11 CPPFLAGS+=-D_FILE_OFFSET_BITS=64 all: hadori.1 @@ -26,12 +26,13 @@ hadori.1: hadori help2man -n $< -o $@ -N ./$< hadori: hadori.o -hadori.o: hadori.C inode.h version.h +hadori.o: hadori.C version.h version.h: test ! -d .git || git describe | sed 's/^\(.*\)$$/#define HADORI_VERSION "hadori \1"/' > $@ clean: rm -f hadori hadori.o hadori.1 + test ! -d .git || git checkout -f -- version.h .PHONY: version.h clean |